2D path rendering with OpenGL very slow on iPad


#1

Hi Jules!

 

Thanks for your time on Musikmesse last wednesday.

As you will remember I had shown you that the OpenGL output on the iPad became extremely slow as soon as "Draw 2D graphics in background" was activated in the JUCE Demo or when the code editor at the bottom is redrawn.

My iPad is a MD371FD/A model.

Could you reproduce this problem on one of your devices?

Do you already know, what could be causing this issue?

 

Thanks and Best Regards,

Gregor

 


#2

Thanks Gregor - was good to meet you at Messe, and yes. I remember the issue - it's on our list of things to investigate this week!


#3

Ok, this just looks like it's a bottleneck in the iOS openGL 2D rendering engine - we're going to be making some effort to optimise the GL renderer soon, which should hopefully make a difference for you.


#4

this will be a welcome improvement! Thanks for looking into this. 


#5

Hi Jules!

 

Are there any news on this issue?


#6

Nothing to mention right now, but it's definitely a priority for us!


#7

I'm also experiencing slow 2D rendering in the demo (Render Time: ~up 190ms):  

- only if I run the 'OpenGL 2D' demo prior to the '2D Rendering'.

- running other demos and relaunching does have no effect with exception of running the 'OpenGL' demo, which seems to restore good performance. (Render Time: ~34ms)

 

iOS 8.4, iPad Air 2


#8

The demo can run with different rendering engines selected, so I guess that once you've selected the GL demo, it has switched on the GL renderer, and it stays enabled when you move to other tabs?


#9

NanoVG might be worth investigating as a faster juce render backend. Its interface is very similar to juce's path interface:

https://github.com/memononen/nanovg

 


#10

Hi Jules!

Is there any schedule when this optimisation might be done?

Can you roughly say if this will happen within the next month?

 


#11

Unlikely to be so soon, but as said above, it's an important priority for us.