4.2 failing on OSX


#1

I’ve just tried downloading the latest JUCE (4.2) from GitHub.
For a start I get errors in the ProJucer’s Build tab.
Actually even before that, I notice there appears to be an OSX ProJucer binary but no Windows or Linux binary. Why not have all three binaries side-by-side? Wouldn’t that be cleanest?
Anyway, onwards…
So I’m looking at the ProJucer in the ProJucer.
Maybe if I create a fresh project…
Noop, still errors albeit different ones.

(EDIT: minor annoyance: everytime you create a new project it starts you off in your home folder – could it please start you off in the containing folder for the last project you created?)

I try “save project and launch in IDE”. But Xcode shows a bunch of build errors.
Lemme try screenshots.
ooh drag drop images…
hmm… It is stalling on “uploading 100%”

Uploading…

π

EDIT: ok I’ve uploaded an image onto my server:


#2

mmm did you checked if the modules path are correct?


#3

yup… grr I have to type 10 chars :expressionless: could someone remove this limit?


#4

ooh wait.

I don’t have any modules! And clicking “download and add a module” produces the following error:

This can’t be right!

I’ve just done another test starting from scratch, making a fresh GUI app, correctly choosing the modules folder.

But the same thing happens!

Looks like a bug…

π


#5

does that still happen if you manually drag modules subfolders in Projucer?


#6

I’ve tried doing this:

but…

π

PS clicking “download and add a module…” gives:

PPS Nice to see that drag dropping images is now working


#7

Those download/install update buttons no longer exist. You must be running an old version of the Projucer.


#8

jeeeeez I have just been one dumb bunny.

I was double-clicking on the Projucer.jucer file (https://github.com/julianstorer/JUCE/blob/master/extras/Projucer/Projucer.jucer) in my local copy thinking it was the OSX binary.

(hence some comment of mine somewhere else saying “Why not have the Projucer binaries for all OS side-by-side”).

And it was of course opening up the new Projucer’s .jucer file using some existing Projucer.app on my filesystem.

I wonder if watching the OJ trial series has damaged my IQ. :confused:

π

PS I can’t close the issue … might be nice if that functionality was there.