5.1.2 Build Error for IAA - not solved


#1

44 AM

In a working 5.1.0 project, updating the ‘modules’ and ‘JuceLibraryCode’ folders to 5.1.2 causes the link errors shown here:

The ‘Shared Code’ portion of the project will build, but the ‘Standalone Plugin’ portion will not.

The preprocessor definitions JUCE_USE_CUSTOM_PLUGIN_STANDALONE_APP & JucePlugin_Build_Standalone seemed to be incorrect or undefined - but manually overriding them did not change the results.

In ‘Appconfig.h’ changing JucePlugin_Enable_IAA 1 to JucePlugin_Enable_IAA 0 enables a clean build, but, of course, that would not work for me - as I’m trying to get interapp audio working…

Ideas?


#2

You should re-save your project with the latest Projucer. Did you do that?


#3

Well, thank you for that pearl of wisdom! Seems to have done the trick.

I suppose I should become more familiar with the Projucer app…


#4

Well, I spoke too soon. The Projucer wrote over the Juce folder location and the project started using the old 5.1.0 modules instead of the new 5.1.2 modules. After moving back to the 5.1.2 files, it builds, but the signing certificates aren’t working because the bundle identifier needs a tweak. Changing the bundle identifier causes the original error ( see screen shot at top ).

Still looking for a solution…


#5

Update:
I can successfully build using JUCE v5.1.0 & v5.1.1.
Something changed in 5.1.2…


#6

I’ll have a look but…

…changing the bundle id can in no way cause the linking errors you are seeing above.


#7

5.2.0 Update.
Still broken.
Can’t build the example IAAE effect or my own with any version of JUCE past 5.1.1.
Same error in both 5.1.2 & 5.2.0 ( see initial post ).


#8

A fix will appear shortly.

The breaking issue this time was due to very recent namespacing changes, the original issue was fixed ages ago.


#9

Good to know. I appreciate the feedback. Thanks!