64-bit VST in OS X


#1

Hi Guys!

I'm new here and I'm building a new plug-in with Juce which in general seems to work very well so far. But I'm having trouble getting the host (Ableton Live 9.2.2 in this case) to detect the 64-bit build of the plug-in. The 32-bit VST works, as does the AU version (both in 32 and 64-bit), but I cannot get Live to list the 64-bit VST so I cannot test it.

Any ideas?

Sorry if this has been asked before, I did do a search but it didn't turn anything up other than build issues.

Thanks!

/Mike


#2

If you did build x64 supported binary for me most of the time the simplest resolution is as follows:

- Delete all plug-ins wraps from ~/Audio/Plug-Ins

- Delete all plug-ins wraps from /Library/Audio/Plug-Ins

 

I've attached a simple shell script I've made for this.

Basically it'll ask your SU password and expects 'y' (not capital) for actually deleting the plug-ins.

Usage:

sh remove_plug.sh YourPlugInName

It'll remove all (VST/VST3/AU/RTAS/AAX) if exists.

if [ -z "$1" ]; then
    echo "error, plug-in name missing!"
    echo "Usage: sh remove_plugin.sh [PluginFileNameWithoutExtensions!]"
    exit
fi

read -p "Warning! this will remove all plug-in locations, Are you sure? " -n 1 -r
echo    # (optional) move to a new line
if [[ $REPLY =~ ^[Yy]$ ]]
then
    # AU
    echo "Removing Audio-Unit..."
    sudo rm -rf /Library/Audio/Plug-Ins/Components/$1.component
    # RTAS
    echo "Removing RTAS..."    
    sudo rm -rf /Library/Application\ Support/Digidesign/Plug-Ins/$1.dpm
    # AAX
    echo "Removing AAX..."    
    sudo rm -rf /Library/Application\ Support/Avid/Audio/Plug-Ins/$1.aaxplugin
    # VST
    echo "Removing VST..."    
    sudo rm -rf /Library/Audio/Plug-Ins/VST/$1.vst
    # VST3
    echo "Removing VST3..."    
    sudo rm -rf /Library/Audio/Plug-Ins/VST3/$1.vst3
fi

read -p "Would you like also to remove any local/user folder plug-in?" -n 1 -r
echo    # (optional) move to a new line
if [[ $REPLY =~ ^[Yy]$ ]]
then
    # AU
    echo "Removing USER Audio-Unit..."
        sudo rm -rf ~/Library/Audio/Plug-Ins/Components/$1.component
        # RTAS
    #echo "Removing USER RTAS..."    
    #sudo rm -rf /Library/Application\ Support/Digidesign/Plug-Ins/$1.dpm
    # AAX
    #echo "Removing USER AAX..."    
    #rm -rf /Library/Application\ Support/Avid/Audio/Plug-Ins/$1.aaxplugin
    # VST
    echo "Removing USER VST..."    
    sudo rm -rf ~/Library/Audio/Plug-Ins/VST/$1.vst
    # VST3
    echo "Removing USER VST3..."    
    sudo rm -rf ~/Library/Audio/Plug-Ins/VST3/$1.vst3
fi

 

 

NOTE: I've renamed it to .txt to be allowed for uploading...

I'll publish it as a git based link eventually for better version control :)


#3

So I tried deleting the .vst and .component but the 64-bit VST still won't show up in Live 9.2.2. Again it works in 32-bit mode, so I think it is not a scanning issue. 


#4

Are you sure you're compiling Universal Binary? also make sure your minimal SDK is at least 10.7.

Last thing, on Ableton Live turn the VST On/Off to re-scan entire plug-ins.


#5

D'oh! Turning VST Off/On to rescan worked, the 64-bit version is shows up now.

Thanks a bunch!

--Mike