AAX Identifier always com.yourcompany.[JucePlugin_Name]


#1

There doesn’t appear to be a way to set the JucePlugin_AAXIdentifier in IntroJucer and as a result it is always autogenerated in the AppConfig.h as com.yourcompany.[JucePlugin_Name]

Note I’m not using yourcompany as a placeholder, it is always using the default bundle identifier even if the bundle identifier has been customized.

so though your bundle ID might be correctly set to com.acme.exploder the AAX identifier will remain com.yourcompany.exploder

While one can explicitly override the JucePlugin_AAXIdentifier by placing a suitable #define in the “user code section” of AppConfig.h, wouldn’t it be better for Introjucer to either:
(a) use the actual bundle identifier (JucePlugin_CFBundleIdentifier) as the default for JucePlugin_AAXIdentifier, or
(b) expose the AAX Identifier in Introjucer’s Config->Project Settings panel, near PlugIn AAX Category
?


#2

Thanks, I’ve added this now.