AAX signing on Windows - Can't find certificate with thumbprint

Hi everyone,

I already signed my AAX on the mac and that works fine with Pro Tools Ultimate. Now I want to sign it on Windows. What I did is that I exported my Certificate from Mac with p12 format and then imported it in Certificate Manager of windows. But I when I run the wraptool command, I get the error below

wraptool Error: pace::eden::thrift::exception::PaceThriftExceptionWire: BinaryDsignException::CodesignToolError, 14, Error signing the specified binary., ossignaturewin.cpp, line 579, Can't find the certificate with thumprint in the certificate stores.

I tried importing it using PowerShell (Import-PfxCertificate) and get the same result. I can see that I already have the certificate (CodeSigning) in the list of certificates in Manage Computer Certificates. and also when I type Get-ChildItem Cert:\LocalMachine\Root\* in PowerShell, I can see my certificate there too.

Any idea? What am I doing wrong?
Really appreciate your help