AAX Touch Automation Broken


#1

In AAX JUCE plug-ins, touch automation is currently broken.

To reproduce:

  1. Load up any JUCE demo plugin. I’m using GainPlugin.
  2. Prepare a parameter for automation. I’m using Gain.
  3. Set the track’s automation mode to Touch.
  4. Record some fast automation.
  5. Hit stop. Leave Touch automation on.
  6. Hit play again. Don’t touch the knob.

What’s occurring:
It appears that there is some built-in interpolation with JUCE’s parameters or something similar. Repeated passes of Touch automation take the existing automation curve and essentially apply a low-pass filter to it.

Is there a way to turn off automation interpolation? We do all required interpolation in our DSP.

EDIT:
I forgot to add… this is not occurring in Logic Pro X, which makes me assume that this is an AAX issue.


#2

We’ve added this to our update Slider from Processor method:

if (std::abs(float(getValue()) - valueToCheck) > 0.001)
{
	setValue(valueToCheck, dontSendNotification);
}

This seems to fix the weird interpolation.