Ability to set/pass a "name" to juce::ThreadPool

OK I’ve pushed a change to develop. In this case we’ve decided to use the using declaration for the nested class. We’ll likely look to review our other use cases in the framework to improve consistency, but essentially our feeling was that this offers the best of both worlds. I understand the point about namespace pollution and we’ll keep an eye on that going forward.

1 Like