Accessibility does not work after calling OpenGLContext::attachTo

I am trying to make my plugins accessible, but I ran into a strange issue: when calling myOpenGLContext.attachTo( *this) in a component (eg the AudioProcessorEditor) the plugin appears as only one accessible Component, and all child components are no longer “accessible”. Everything else works as expected.
This can be reproduced with the Demo Runner accessibility demo by adding two lines:
OpenGLContext oglc; // as member
oglc.attachTo ( *this ); // in the ctor
I am having this issue on Juce 6.1.4 on Mac.
Am I doing something stupid? Can someone help me sort this out? Thanks in advance!

Thanks for reporting! This should be fixed on develop with the following commit:

Please let me know if you are still experiencing any issues after this commit.


Wow, that was fast!!!
Thank you, this solved the issue for me, awesome!

It’s worth noting that this was only affecting the Accessibility Inspector (the testing tool bundled with Xcode) since it relies on mouse events for navigating the accessibility hierarchy. Using VoiceOver and navigating via the VO shortcut keys was unaffected.