Addressing older studio customers -- SOLVED


#1

Greetings fellow Jucers,
I am trying to build my plugin for studio customers that are still using MacOs 10.6 (mainly due to ProTools and the high costs of upgrading)
I set up an old macbook running 10.5.8 with Xcode 3 and the 10.5 SDK,
I need an older version of Juce that i cannot find to run with Xcode, correct?
Anyone with the same problem/experience? Any tips?
Many thanks
Blessings and love to one and all!
Chris


#2

The latest version of JUCE still supports creating apps that run on macOS 10.6. You still need to develop on the latest macOS, but the app that you create will run on macOS 10.6 as long as you set the OSX deployment target to 10.6 in Projucer:


#3

Many thanks Fabian,
do i have to do anything with the SDK’s on my system?


#4

Nope. Don’t touch the SDKs.


#5

The trickiest part would be if you plan on doing RTAS.
I’m not sure how stable is latest JUCE with RTAS so that’s something to evaluate.
(it might work but we didn’t test it, any old plug-ins here are based on Sound Radix forked JUCE 4.3.1:

Another thing,
We’ve been able to compile the PT9 SDK with 10.12 using macOS10.6 SDK.
However with latest Xcode or SDK it fails (I’ve yet to investigate).
So if you’re on 10.13 and Xcode 9.x keep that in-mind.

If you’re using 3rd party copy protection, also make sure you’ve got a version that supports 10.6.

In terms of JUCE, it’s still great that you can deploy for 10.6.


#6

. and I get:

I have not touched the SDK


#7

You don’t need to use older SDK… just set deployment to 10.6.

macOS10.6sdk is only required for compiling the PT9 libs if needed.
Those are linked afterward so for your actual plugin build you should use the latest.


#8

Well I managed to build .VST and AU, but when it comes to AAX…

clang: warning: libstdc++ is deprecated; move to libc++ with a minimum deployment target of OS X 10.9 [-Wdeprecated]
ld: library not found for -lAAXLibrary
clang: error: linker command failed with exit code 1 (use -v to see invocation)


#9

I’m guessing you haven’t built the libAAXLibrary.a library in the AAX SDK, maybe you’ve only built the libAAXLibrary_libcpp.a library?


#10

Also note, when you changed the deployment target, the default stdlib went from libc++ to libstdc++ (hence the warning). You can enforce the libc++ in the XCode exporter settings (for debug and release separately)…

That’s the difference between libAAXLibrary.a and libAAXLibrary_libcpp.a btw. One is linking against libc++ and the other to libstdc++, I don’t know which is what out the top of my head…


#11

Many thanks guys!!
it was the libAAXLibrary.a that was missing!
I built that and now I don’t get the error anymore!