After update to 5.4.7: compile errors on Code::Blocksor Windows

I have compile errors after I updated to version 5.4.7:
“‘mutex’ in namespace ‘std’ does not name a type”
“‘condition_variable’ in namespace ‘std’ does not name a type”

I am using Code_Blocks fr Windows and mingw.

Any clues?

@hstraub which version of JUCE were you using before updating to 5.4.7? 5.4.6 or something older?

Which version of Code::Blocks and MinGW are you using?

I was using JUCE 5.4.5. Code::Blocks is 17.12,
About MinGW, I’m not even sure. And maybe that’s where the problem lies.
Currently trying to update to the latest MinGW…

Installed Code::Blocks 20.03 with integrated MinGW compiler. Still doesn’t compile - just displays another error message now:

juce_FloatVectorOperations.cpp, “internal compiler error: in ix86_compute_frame_layout, at config/i386/i386.c:11693” .

I guess I have to have a closer look at that verison of MinGW…

Gave it another try, same version of Code::Blocks with integrated MinGW compiler.
This time there is yet another compiler error message:
“error: can’t write 32 bytes to section .text of … \JuceLibraryCode\include_juce_gui_basics.o: 'File too big”

Very strange indeed…

juce_gui_basics requires the /bigobj flag to build under MSVC, the equivalent of which is -Wa,-mbig-obj under MinGW. Adding -Wa,-mbig-obj to your CodeBlocks compiler flags should allow the build to continue.

Perfect, that worked, thank you!