AlertWindows garbled when using 10.6 SDK / XCode 4.3.2


#1

I’ve compiled my latest plugin beta using the 10.6 SDK inside XCode 4.3.2 running in OS X 10.7.4, to maintain backward compatibility with 10.6 users. Everything is working fine, except for the text in my demo nag, which uses the AlertWindow class (latest Juce tip as of this posting.) What’s funny is that the buttons aren’t garbled, just the title and message of the AlertWindow itself.

PS - all the tooltips in my plugin are similarly mangled.


#2

This is to do with the AttributedString and TextLayout which is used to render alert windows, pop-ups and all sorts of useful stuff. Are you sure you are using the latest tip because there has been a lot of work on this recently.

Do the issues persist if you use the 10.7 SDK and set the deployment target to 10.6? This is the preferred Apple way of doing things.


#3

I’m definitely using the latest tip as of a few minutes ago (2.0.21.) No worries there. I’m aware of the changes…

I never knew that, but I’ve just tried that, and the behavior is identical. The garbling text only happens when running the plugin in OS X 10.6, I’ve tried VST in Cubase and VST and AU in Reaper. When I run the plugin in these same hosts in OS X 10.7, the text is fine.

Thanks for the advice, even though the issue remains a mystery, I’m happy to know about the deployment target field (I’d never noticed it before.) It’s nice to not have to compile using an older SDK! 8)


#4

An update - one of my beta testers has reported that he’s not getting the garbled text on his 2011 Intel Core i7 based MacBook Pro running 10.6.8. The test machine that was getting the garbled text, however, is much older - a first generation Intel Core Duo (32 bit) based MacBook Pro.

If this bug is specific to an older mobility video card, then I’m not overly concerned about it. It’s evident from this (and other issues, such as backlit keys not working in 10.6.8 on many older Mac laptops) that Apple is pretty lazy about testing their OS releases on legacy (but supported) hardware. Thanks again for your help and insights!


#5

Judging by that screenshot, I would say that you were using Juce code older than May 8, 2012.

This exact bug came up earlier:
http://www.juce.com/viewtopic.php?t=9178&p=52217

And it was fixed on May 8:
http://juce.git.sourceforge.net/git/gitweb.cgi?p=juce/juce;a=commit;h=cd7cdacfd1b0088e31aa37d1ed8b2fb74b1d1e72


#6

I need to rebuild the project… I just realized I had local module copies enabled by mistake. Still getting used to modules.

Sorry, feel free to delete the thread, I feel stupid now. :shock: