ARA plugin not supported by Cubase on macOS ARM

I’m still in the process of replacing JUCE 6 with JUCE 7. On macOS, there is no sound with Cubase Artist 12 build 205 (I tried with my ARA plugin and with the ARAPluginDemo). There is sound if Cubase is opened with Rosetta. I tried with the JUCE develop branch (61fd882) and ARA_SDK 2.1.0 (e87afbd).

P.S. It works with Celemony’s JUCE fork

1 Like

I tried with JUCE 7.0.2 and the issue is still there. I tried to debug, ensuring the juce::ARAPlaybackRegion is well-functioning and the buffer is well written but I couldn’t find the issue. It seems that Cubase is not using the plugin audio output… I tried to compare with the same plugin generated with Celemony’s JUCE fork but the ARA organization is so different, I didn’t manage to find a clue either.

I am looking into this issue right now, and hopefully a fix will be provided soon.

The bug seems to be triggered by the fact that Cubase isn’t calling IComponent::activateBus() for ARA plugin instances. It’s not mandatory to call this function if all information is provided in the call to setBusArrangements(), but it seems to be causing a problem with how VST3 and JUCE channels are mapped to each other. The channel mapping changed since JUCE_ARA has been forked, which is why it’s not affected.

1 Like

I created a patch that activates channels in setBusArrangements(), and this is sufficient to have sound in Cubase.

cubase-ara-sound.patch (1.4 KB)

However, while looking into this, and reading the VST3 documentation more carefully, I’ve come to the conclusion that the host should be mandated to call IComponent::activateBus(), and this might be a bug in Cubase. So the patch is only a workaround and the fix may be coming from Cubase.

I have created a ticket about the issue with Steinberg, and I will update the this thread when I know more.


Thank you very much! I hope they will fix it soon :crossed_fingers:

Thanks, it works great!

The patch has merge conflicts with other changes since to the VST3 wrapper, so if anyone wants to use it, note that it is merged to the SR juce7 branch.

1 Like

FYI, I tested Cubase 12.0.50 and the problem doesn’t seem to be solved yet.

Has anybody tried with a newer version of Cubase (12.0.52)? And is the patch still relevant? The patch cannot be applied on the master branch anymore - JUCE 7.0.7 - 22df0d2.

The problem is still unresolved on Cubase 12.0.52. For those who want to apply the patch on JUCE 7.0.7 - 22df0d2: Fix channels management for ARA support in Cubase.patch (1.7 KB).