Atlthunk.lib?


#1

I would appreciate your help on this one:
I am trying to compile the “hello world” project and this is what I get

"Compiling…
Main.cpp
JUCE! Linking to: jucelib_static_debug.lib
Linking…
LINK : fatal error LNK1104: cannot open file "atlthunk.lib"
Error executing link.exe.

juce_application.exe - 1 error(s), 0 warning(s)"

I am using VC6 sp5, win2000. I tried to follow all the installation instructions, but probably I am missing something. Please let me know if you know what causing it.

Thanks!


#2

Wierd. Have you got ATL turned on or something? My juce projects compile with it turned on or off (which means off normally but I tried it turned on). I’m using VC++7.1 though.

no idea mate. I’m sure Jules or someone will be along soon…


#3

Hi - weird. Exact same problem here. VC6, SP5, processor pak installed (for sp5).

same exact link error. The reference to the atlthunk.lib is in the \PlatformSDK\include\atlbase.h

but thats all that I was able to figure out… there is no atlthunk.lib anywhere on my HD.

Nothing comes up on a MS search for atlthunk.


#4

removing #include <atlbase.h> from juce_win32_Windowing.cpp (line 48) solved the problem - Thank you for the advice!


#5

…ok, that’s interesting…

It does still seem to compile without that… which is strange, because I must have included it for a reason!

I guess I’ll get rid of that line for the next release, and hope there wasn’t some subtle reason that I’ve since forgotten!


#6