AU component not found for small amount of High Sierra Users

A small amount of users are running into this problem:

Started validating: /Users/user/Downloads/Plugin/MacOS/Manual Install/plugin.component

Random seed: 0x249495e

Validation started: 10 Oct 2020 8:18:04pm

Strictness level: 5


Starting test: pluginval / Scan for known types: /Users/user/Downloads/Plugin/MacOS/Manual Install/plugin.component...

Num types found: 0

!!! Test 1 failed: No types found

FAILED!!  1 test failed, out of a total of 1

Finished validating: /Users/user/Downloads/Plugin/MacOS/Manual Install/plugin.component


The plugin is also not found when in Macintosh HD/Library/Audio/Plug-Ins/Components.

This problem has only occurred for High Sierra users. Restarting the user’s system has solved some of the cases, but not others.

Has anyone encountered this problem?

This is presumably when testing with Tracktion pluginval?

I have noticed the same error when trying to test a plugin that is not in the standard AU plugin folder (Library/Audio/Plug-Ins/Components).

Furthermore, if there is a component in the standard location that has a matching plugin name, then it will be tested instead of the one that I asked pluginval to test.

I haven’t need to restart for a plugin to be detected, however. Placing a plugin in Library/Audio/Plug-Ins/Components has been sufficient for pluginval to detect it. But I am on Catalina, not High Sierra.