AU no longer mono?

Hi, just rebuilt an AU for the first time with 5 (5.0.2) and when I open a test set it says that the mono plugin is no longer avaialble. Checking in plugin manager only shows a stereo version of the plugin, even though it’s channels are marked as {1,1} in Projucer.

Has anyone else seen any issues with this? thx

Not sure if it’s related, but my standalones are now starting up with:

Is it possible to disable this as my plugin doesn’t use audio…

I’ve removed the {1,1} from Plugin Channel Configuration and still appear to be generating a stereo plugin - is there anyway to force a mono plugin as I don’t want make users reselect a stereo version of the plugin in existing sets…

However, removing the {1,1} has stopped the audio feedback message from appearing.


Hmmm, just tried to reproduce this but I can’t. I created a new empty project with the Projucer and changed the configuration to {1,1}: everything worked as expected for both AUv3 and AU.

That’s expected: you are claiming that your plug-in has inputs and outputs. As a safety measure, JUCE will mute the input to avoid a nasty feedback loop. Simply click on the Settings button in the notification bar

and unclick “mute audio input”

This will be saved to disk so that you don’t have to do this again when you restart the standalone plugin.

I guess I don’t want the user to have to do this - the plugin is MIDI only and generates no audio so is kind of confusing. As said though, I’ve removed the {1,1} and now this message has gone away. I only ever entered the {1,1} to fix an issue back when moving to 4.3.0 so this is fine. thx.

Why not use a midi effect plugin?

See JUCE/examples/PluginSamples/Arpeggiator.

Some hosts (I think it’s FL studio iirc) treat MIDI plugins differently and don’t place them into the instruments category therefore hampering their intended use in this case (I’m not an FL user so don’t really know the details, but got feedback from users)

When first working on the plugin I went through all the combinations (should have noted them down), but basically setting “Is a Synth” and disabling “MIDI effect plugin” was the only way to get it to load sensibly into all hosts (there’s probably an audit trail on the forum here somehwhere :slight_smile: )

removing the AUv3 from the build has resulted in a plugin thats mono & stereo again…

Hmmm… Did you re-scan the plug-in in Logic? I can’t seem to reproduce this.

yes, i was rescanning in Plugin manager each time. are you saying that with AuV3 enabled you get the mono and stereo?

No. For me it always seems to work. You can try it yourself: just create a new audio plug-in project and change the channel configuration field to {1,1}.

ok, will give it a go shortly - just trying to get some stuff out… just so we’re on the same page, it was ultimately the inclusion of the AUv3 that looks to have been the cause, not the presence or absence of the {1,1}

Hi - sorry for delay, tried reproducing this today and can no longer reproduce… Don’t know whether something had got in a weird state