AU plugs don't show up in Maschine, what could it be?


#1

I’m building test AU plugins straight from the unaltered template code generated by Introjucer. The plugins show up in Ableton Live, but not in the NI Maschine standalone host. I wonder what could be the problem. I’ve build them as universal intel 32/64bit. All other AU plugins do show up in Maschine.

Anything you can think of that might be the cause of this?

Here are the 2 compiled plugins, just in case:
https://dl.dropbox.com/u/8165817/plugs/TestFx.component.zip
https://dl.dropbox.com/u/8165817/plugs/TestSynth.component.zip

I’ll contact NI as well but I it might take a while for them to respond…


#2

Ok it’s nothing Maschine specific apparently they also don’t pass the Logic Studio scan. Are there any common pitfalls I can look into?


#3

try running auval - that might give you some clues.


#4

Thanks for pointing me to auval. I have things working now, although I’m not completely sure what the problem was since I found several issues. I had multiple test plugins with the same (default) plugin code, so I can imagine that messes up the plugin scan process. Running auval I also discovered some dodgy plugins that kept auval running forever. I removed them too.

Anyway I’m glad things are up and running now. :slight_smile:


#5

I had a similar issue. The plugin worked everywhere just not in maschine. The cause was a wrong “Bundle OS Type code” in the “info.plist” file. It worked after i set it to BNDL.