AU Validation: ERROR: -1 IN CALL Parameter Value's String

Hi All,

I ran into a reported issue with 2 of our plugins not showing in the latest version of Logic so have tried updating them to JUCE 7. For some reason now I am getting these errors which I haven’t seen before:

# # 818 Global Scope Parameters:

ERROR: -1 IN CALL Parameter Value’s String
ERROR: -1 IN CALL Parameter Value’s String
ERROR: -1 IN CALL Parameter Value’s String

I’ve updated all the parameters to use “juce::ParameterID”. I’m unaware of any other changes I need to make?


Which JUCE 7 commit are you using?

We very recently updated the AudioUnit SDK on the develop branch, but this change isn’t on the master branch yet. It would be interesting to know whether this commit is the cause of the problem.

1 Like


Thanks for pointing this change out. I was using the 7.0.2 master branch but moving over to the develop branch seems to have fixed the issue.

No real idea what could be causing it. In these plugins I do construct parameters in a bit of a strange way due to necessity but odd that it would break and then start working with a new sdk?


I had this issue recently because I was using a null valueToTextFunction, perhaps that’s also your case.
See this thread for more info and the relative fix by Reuk on the develop branch:


Ahh, great thanks. That would explain the problem.