audioDeviceManager.initializeWithDefaults(0,2) doesn’t seem to be picking up the default audio device in 5.4.3 when I role back it does.

This was a little blessing in disguise for me as it identified a little bug on my system but is there a fix for this? a little googling others seem to be having similar issues with other methods.

Ps. Rolling back to 5.4.1 (4th Dec build)

Have you tried the latest tip of the develop branch? There have been a few ADM changes since the 5.4.3 release.

Nope but I will do. I usually avoid dev branches as it’s not been relevant to my products but there is a definite difference in behaviour. Is the head of that branch likely to behave more like 5.4.1?

Thx IK

It’s always worth checking the develop branch before reporting issues as it’s moved ahead quite a bit since the last release and the problem may have already been fixed. I’m not sure if your specific issue has been solved but, like I said, there have been a few device manager changes recently.

Well I do want to check out the new shared resource pointer as I’m currently passing around an asset class with a shared pointer for resources like images and program state. which was a huge step up from my dirty statics but still seems a little unclean from a code stand point.