backSlash problem using environment variable with introjucer


#1

Hi Jules,

I would like to declare the RTAS Folder in Introjucer using a windows environment variable.

My variable is named $(RTAS80SDKPath), and is set in windows 7 as "C:\SDKs\PT_80_SDK"
When I type the full path, it compile fine). When I use the variable, it compile everything as well, but fail to link the DAE.lib because the backslash are truncated :
C:SDKsPT_80_SDK\WinBag\Release\lib\DAE.lib

Any tips that would help me to get the proper formatting, without breaking anything else in IntroJucer ?

Thanks !

Salvator


#2

…so you mean that in the introjucer, you’re setting your path to $(RTAS80SDKPath) ?

The introjucer will just dumby copy that into the definition, so there’s no chance at that stage for it to add escape chars or anything. I’m really not even sure at what stage the env variable would be substituted? Is the compiler doing that?


#3

There’s a possibility that your path’s backslashes are parsed as escape sequences (ie: “\n”). (You won’t get issues when using the environment variable with single backslashes in the Visual Studio project settings…)

Try the path like such: “C:\SDKs\PT_80_SDK”


#4

aha ! too easy ! It worked, thanks !
I expected something like that or a need for quote, but as the include paths were working fine (only linker failed) I searched at the wrong place…

@ jules, yes introducer send info straight like this include paths :

$(RTAS80SDKPath)\AlturaPorts\TDMPlugins\PluginLibrary\ProcessClasses .....

Salvator


#5

well, in fact it was not that easy.
Using double backward slashed worked at first (due to some cache probably), then while the linking was OK, the include was broken.

It finally worked using forward slashes in my environment variable.
i.e. "C:/SDKs/PT_80_SDK"
In case this is useful for someone else …

Salvator