Blocks synthdemo not working?


#1

Hi, just testing my new block and the other 2 demos seem to work but the synth demo always shows “Connect a lightpad to play” even though one is connected. The block does seem to respond however, but no audio is output.

Cheers


#2

What type of BLOCK do you have connected?


#3

A lightpad-M


#4

The program is implemented in a way where the message will always be displayed even with a connected block.

One problem I can think of is that it initialises with the default audio device and may be somehow selecting the wrong device.

Have you tried updating the firmware of the block? I just tested with an M and it seems to work fine on my side.


#5

hi. updated the firmware no change.

I also can’t change between any of the demos without shutting down/restarting the block. Is that the same for you?


#6

The Littlefoot program is loaded dynamically every time the JUCE program is run so there shouldn’t be any problem switching unless the previous program is stuck in flash memory.

Try a hard reset of the device as described on the ROLI support site.


#7

hi - thx.

tried that - i think the reset worked (the block clears and shows the battery indicator)

still same behaviour - if I select blocksdrawingdemo, everything is fine, but clicking on either of the other 2 demos make the block unresponsive until i power it down and up again, or close down the demorunner and start it up again.

FYI, switching apps on the ROLI Dashboard is not a problem - just seems to be the demos that are behaving strangely.


#8

If I understand correctly, you are loading the synth demo through the Dashboard?


#9

No, through the JUCE demo runner.

Everything through the Dashboard is working ok. When I try to run demos from the demorunner is when I’m having problems. thx


#10

Ok got it, will get that fixed soon


#11

Should be fixed on develop shortly.


#12

great, thx for that. One other question, is the source code available for the programs in the Dashboard? Would make a great learning resource. thx


#13

Check out the factory script folder.


#14

thx. synthdemo fixed now - still can’t switch between the demos without shutting down demorunner/restating the block however. Looks like there might be a hardware fault on the block so maybe this is causing an issue.


#15

It appears you have to restart the block to switch between demos but no need to shutdown the Demorunner.


#16

ok, thx - at least it’s not my block then - shutting down the demorunner seems to achieve the same result