Browser plugin, upgrading from 1.53 to 2.0


#1

Hi,

Since our browser plugin, created with juce 1.53, doesn’t work on Lion in both safari and firefox even with build target set to 10.7, I’m hoping upgrading to juce 2.0 will do the trick. However, until now I’ve failed to upgrade because I get error after error.
In my last attempt, I simply copied the “browser plugin demo” project and added my code to it. Before I added my code to it, it did compile. Adding my code gave some simple fixable errors like the return value for getJavaScriptObject() apparently is now not “const var …” anymore, but “var…”. Also, I used #include “JuceHeader.h” instead of the old #include “juce_IncludeBrowserPluginInfo.h” in some different files.

When i try to compile, it gives me the following error :

NSObjCRuntime.h : Parse issue, expected unqualified-id.

This file is included indirectly included in Juce_BasicNativeHeaders.h (which uses <Cocoa/Cocoa.h>).
This is just one of the many errors. The next is about Unknown type name NSString, etc etc.

Since I’m totally noob in using a mac and also building stuff on a mac, I have no clue.

Does anyone have an idea what can be wrong and how to fix it ?

Thx


#2

Have you got the latest Xcode + SDKs?


#3

Xcode 4.5.1

Dont know how to check version for the latest SDKs ?


#4

Tried building it to OSX 10.7 and 10.8, both the same errors, if thats what you mean by “SDKs”.


#5

fyi:
Don’t know how exactly, but I finally got it to build. I decided to simply use the plugin demo project, remove juce sample code, and add my code. Also, I reduced the use of “#include JuceHeader”. Fixed some minor incompatibility issues, recreated info.plist (which was corrupted somehow). So in the end, I don’t know exactly what fixed it.

It did fix my problem in firefox (with the 1.53 plugin, firefox became extreme slow), however, at this moment it still doesn’t work in chrome (as stated in a new thread).