[BUG] Scroll blocks on treeview


#1

Hi Jules,

I’ve found that the treeview, when scrolled all the way down, will block incoming mousewheel scoll’s when you close any of the items. This can be reproduced in the treeview demo. In order for it to work you have to resize the window so that it retains the scrollbar when having only 2 items open.
If you drag the scrollbar, it will again receive the mousewheel.
This is reproducible in both 1.53 and the git version.
If you manage to fix it, i’m curious about what exactly caused it. This is because i’m stuck to using 1.53 for now and need to incorporate any fixes to it.


#2

Sorry, I can’t seem to reproduce this… Can you explain exactly what I should do to make it happen?


#3

this isn’t any help whatsoever, but i’ve seen this happen too. I’ll see if I can figure anything out when i get home [i’ve definitely had it happen on my macbook, but can’t seem to make it happen on this windows pc at work]


#4

Get on a mac. (I’m using the trackpad of a mbp, on snow leopard, haven’t tried it on Windows…)
Build and run the jucedemo, go to the treeviews demo.
Resize the window to it’s minimal height, making sure there’s no horizontal scrollbar.
Unfold all the nodes, then scroll down to the last one and fold it in.
Scrolling should now be disabled.
I find that unfolding the node again restores scrolling, as well as a horizontal scroll (when there is a horizontal bar)
Manually scrolling the vertical bar restores it as well.


#5

No… sorry! I’m also using a MBP (though the OS will actually be irrelevant to this), and have done exactly what you said, but I just can’t make it happen!