Build problems [juce_amalgamated.cpp:254590:27]


#1
atom@suonko:~/devel/edoapp/build/lnx$ make CONFIG=Release
==== Building Edo ====
juce_LibrarySource.cpp
In file included from ../../src/Libraries/juce/juce_LibrarySource.cpp:15:
../../src/Libraries/juce/juce_amalgamated.cpp:254590:27: warning: extra tokens at end of #ifdef directive
In file included from ../../src/Libraries/juce/juce_amalgamated.cpp:751,
                 from ../../src/Libraries/juce/juce_LibrarySource.cpp:15:
../../src/Libraries/juce/juce_amalgamated.h:53673: error: âNSViewComponentâ does not name a type
make[1]: *** [Release/juce_LibrarySource.o] Error 1
make: *** [Edo] Error 2

i remember having a similar problem when using ALSA, but it doesn’t matter if i turn ALSA ON or OFF in juce_AppConfig.h the same error occurs? Is this a known issue ?


#2

It seems to think it’s doing a mac build… Perhaps your compiler hasn’t set the ‘LINUX’ preprocessor flag for some reason…?


#3

I wish i’m using your premake thingy to do the build, here is some proof

atom@suonko:~/devel/edoapp/build/lnx$ gcc ../../src/Libraries/juce/juce_LibrarySource.cpp -DLINUX -D_LINUX -I../../src -I/usr/include/freetype2
In file included from ../../src/Libraries/juce/juce_LibrarySource.cpp:15:
../../src/Libraries/juce/juce_amalgamated.cpp:254590:27: warning: extra tokens at end of #ifdef directive
In file included from ../../src/Libraries/juce/juce_amalgamated.cpp:751,
                 from ../../src/Libraries/juce/juce_LibrarySource.cpp:15:
../../src/Libraries/juce/juce_amalgamated.h:53673: error: âNSViewComponentâ does not name a type

#4

Ok, that’s not the problem then.

Is this the GIT tip you’re using?


#5

yup always

atom@suonko:~/devel/juce$ git pull
Already up-to-date.
atom@suonko:~/devel/juce$ gcc -c -D_LINUX -DLINUX juce_amalgamated.cpp -I/usr/include/freetype2
juce_amalgamated.cpp:254590:27: warning: extra tokens at end of #ifdef directive
In file included from juce_amalgamated.cpp:751:
juce_amalgamated.h:53673: error: âNSViewComponentâ does not name a type

#6

Sorry, it’s just a typo. Will check in a fix shortly.