Building a VST plugin for Nuendo with VS 2017 [SOLVED]


#1

Hi, im trying to add to Nuendo a plugin compiled with Juce but the DAW dont recognize that.

The project is the initial code when you create a “audio plug in project”. i don’t modified anything.
the window with the message “hello, world!” should appear

when i put the .dll on the plugin host, it open normally.
i copied a .dll file from a comercial plugin into the Nuendo’s folder, and it recognized the (comercial) plug in. But not the compiled with Juce.

This is my first time working with Juce. Im using VS2017

maybe im doing something wrong in the VS2017.
Can anyone help me?


The problem was that the plugin (x64) and the DAW (x32) had different architectures.
It was solved changing the architecture in the Projucer, in the panel of “exporters”, to Win32.
Thanks again XenaKios.


#2

Is the bitness (32/64) correct between the plugin and the host?


#3

thanks for the fast reply.

i’m not sure. How can i verify that?


#4

x86 is 32 bit, x64 is 64 bit. I would suspect latest versions of Nuendo are 64 bit. (The plugin and the host must generally be of the same architecture.)


#5

the program its installed in the (x86) folder, then it’s 32 bits program, I guess.
Even though my operating system is 64 bits.

this could be the problem?

can i export the plugin with x32 architecture?
What you recomend me?


#6

Projucer defaults to exporting Visual Studio projects with only 64 bit builds set up. You can change that to 32 bit in the Projucer CPU architecture setting or add the 32 bit build option in Visual Studio directly. (If you change it in the Projucer, you will of course have to re-export the Visual Studio project.)


#7

oh man, thank you! that was the problem.
thanks for your time!