Building an Audio Plugin


#1

Hello,

I am in the process of making an audio plugin however I’m a little confused why things aren’t quite working.
Before to learn Juce I have created a GUI with a simple component with sliders, buttons, combo boxes and an Audio Thumnail. My Ui would load an audio file and paint it in a thumbnail and also play it.

Now I was in the process of making my interface design an interface for a plugin so I created a Plugin project in the Introjucer and tried to start adding components on top of that. However just adding a button exactly the way I added it on my previous GUI project(this time in the ProcessEditor), I get this error:

[color=#0000BF]1>------ Build started: Project: ssPluginUi, Configuration: Debug Win32 ------
1> PluginEditor.cpp
1>LINK : fatal error LNK1104: cannot open file ‘.\Debug\ssPluginUi.dll’
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ========[/color]

Could someone please help me out, I really don’t know why just adding a simple button would cause this. Do I need to do somethign different to add Ui components now that it is meant to be a plugin interface?

Many thanks.


#2

Were you able to get the Juce Demo compiled and running? What about the Juce plug-in host and Juce sample plug-in?


#3

Hello,

Yes, got all three of them running smoothly. Even the plugin i’m trying to build on worked fine displaying the “Hello World” window. It’s just when on that same Hello World plugin I tried to add a button to see if I can build on it that I got the error.
Any thoughts? Is there a difference I must take into account when making an interface in a GUI project as opposed to making the interface of a plugin?

Thanks!


#4

The error just says that it can’t write to your binary - probably just because you’ve still got it open in another app or something?


#5

this happens sometimes on windows7 with whatever extra services for disk pre-fetching turned on, i got this a lot with the linker, i always had to run the build twice cause the 1st time the output binary was busy.


#6

Thanks for the replies!
yeah actually I have to rebuild again for it to work fine. I am having a weird problem though which is, I run the plugin interface in the plugin host and it works fine, even some small funcionality such as displaying a waveform,etc (no audio processing yet). The strange thing is that when I run it on a mac everything works normally, but when I am at my Windows 7 computer everything is fine until I hit the close button (the ‘X’ at the top right corner for Win), and everytime the plugin host crashes. This happened also when it was a GUI project instead of a plugin project. I could run it but on close it would crash.

Has anyone encountered something similar? why will it crash only on Windows.?


#7

Did you try to debug it?
On windows you can do it by loading the plugin in your host (as usual) and then http://msdn.microsoft.com/en-us/library/c6wf8e4z.aspx
Once you attached visual studio to the host’s process you’ll be able to debug your plugin and see what’s going on.