Building with Zlib Disabled gives build errors


#1

I’m building on an old Raspberry Pi 1 (B) - (which takes ages, and struggles to get through some of the GUI modules. Running out of RAM.

Swapfiles can help, but not recommended on SD Cards!), I’m using ZRAM (to maximize the RAM I do have).
So I considered disabling some features I wasn’t using. (ZLIB/Webbrowser/Live edit stuff)

I got some spurious errors (from memory undefined types/defines) after disabling ZLIB option in Projucer project.

Sadly I can’t give you detailed errors I saw as I’m re-building the code now, and it takes ages, but if I get a chance later, I will.

I ought to be easy to repeat - Just disable ZLIB and build.


#2

When you say “with zlib disabled”, what do you mean?

AFAIK the library doesn’t have a flag that disables zlib, because it’s needed by other things like ZipFile and some other internal classes.


#3

Hi Dub,

You can’t just disable JUCE_INCLUDE_ZLIB_CODE. the help at the bottom of the Projucer says:

So you’ll still need to link to zlib and provide Juce with the headers.


#4

Aw! Thank you. TBH _
(excuse generator activated),_

  1. it was late at night (early in the morning),
  2. Pi/TV display it’s using is on the other side of a room,
  3. I was desperate to get the damned thing to build before going to bed. _
    {excuse generator deactivated!}_

Apologies


#5

FYI, the real target is a Pi zero (even lower spec than a Pi 1A!) - The app just twiddles the GPIO lines in a funny way to draw Lissajous figures on a mobile phone (after a just-for-fun online bet / challenge I accepted ).
I’m using Juce just because I wanted to show-off and have a nice GUI / mimic screen

Building on mostly on a Pi 1 then swapping over to a Zero ought to save me some time in the long-run (AFAIK, I can’t take advantage of building on a Pi 3/quad core 64-bit Pi for this)