Can't build with VS2017?


#1

I’m sure I’ve simply mucked up my VS 2017 install, but has anyone come across this error before? I cloned the 5.1 branch, installed VS2017 with C++ support. Tried opening the Projucer solution and hit this error log?


#2

I’ve not seen that one before.

What is being migrated? Are you opening the VS2017 Projucer solution, or the 2015 or 2013?


#3

I’m simply trying to open the 2017 project, with VS 2017? Strange. I can’t think what it’s trying to do. Perhaps I accidentally installed the wrong version of 2017. I’ll double check tomorrow that I installed the community version. I may try to simply reinstall 2017 and see where that gets me.

Thanks as always for the prompt reply.


#4

i’ve just done a rebuild of Projucer with vs2017 and all fine here


#5

Good to know. I obviously botched up the install of VS2017. :roll_eyes:


#6

as the other poster suggested, it seems to be doing a migration rather than an open suggesting that an older solution file was opened rather than the vs2017 one


#7

I resolved the issue by opening the .vcxproj file and removing the project GUID. I’ve no idea why that worked, but it was suggested on a stackoverflow thread. Hopefully I won’t have to do that each time. I might try to check out another commit and see if I have to do this again…


#8

I think there might have been something fishy going on with my version of git. I reinstalled git for Windows and now everything works out of the box.