Character "x" replaced with multiplication char

For example, string “vst3 x64” is displayed with “x” char as multiplication symbol, which is obviously wrong.

This is happening with some fonts only, like this would be some kinf of font feature ?!?

How to avoid this? I can see this is happening globally on macOS system. Can JUCE override this behaviour?

Any ideas? Thank you!

Presumably this is some kind of ligature in the font. As to how you stop JUCE rendering ligatures is another question (that my quick searches didn’t help with).

Worst case scenario would be to edit the font and remove that {num} x {num} ligature.

1 Like

Ah, thx … for a start, now i know how to call it - “ligature”.

Has anyone ever figured out if there is some way to disable ligatures in juce?

I am having a problem with a specific font I want to use and the ligatures are causing some problems in popup menus. But I tried editing the font with FontForge and it’s not simple at all, and the end result doesn’t come out the same…