Collision between AudioUnit and AudioUnit V3

So I’m working on a synth plugin. I’m testing on High Sierra, and I’m testing – in part – on Ableton Live 9.7.

When I first install my plugin, initially my plug-in doesn’t show up in Live, but then after I reboot, the internal OS plug-in list gets updated and my V2 AudioUnit loads up fine in Live.

At this point, I see my plugin listed when I run

auval -a

And if I run

auval -o -v aumu Acst Dldy

I see passing tests about my plugin. So far so good.

Then, after I run the Standalone version of my plug-in and reboot again, the V3 AudioUnit version of the plugin (which is bundled inside the app) gets registered with the system.

If I run this same command

auval -o -v aumu Acst Dldy

It says that my plugin is Version 3.

If I run this

auval -o -comp -v aumu Acst Dldy

I get info about the V2 version of the plugin.

At this point, if I open up Ableton Live 9 (which does not support AUv3 plugins), I get an error message if I try to use the Audio Unit. In other words, is as though the OS is supplying the V3 version of the plug-in to Ableton rather than the V2 version.

What can be done about this?

1 Like