Compile error with 5.1.1


#1

With current master (5.1.1) I am getting these new errors when building an audio plugin on macOS 10.12 (it worked with 5.0.x):

/modules/juce_audio_basics/native/juce_mac_CoreAudioLayouts.h:218:19:
Use of undeclared identifier 'kAudioChannelLayoutTag_AAC_7_1_B'

/modules/juce_audio_basics/native/juce_mac_CoreAudioLayouts.h:219:19:
Use of undeclared identifier 'kAudioChannelLayoutTag_AAC_7_1_C'

What am I missing?


#2

Tried resaving your exporter for XCode? I just got from 5.1.0 to 5.1.1 no hassle.


#3

Ah, right, I forgot to add that I resaved after updating to 5.1.1… so, everything up-to-date.


#4

Are you getting only the two errors you mentioned in your first post, or are you getting more errors?


#5

It’s only the two errors that I get. However:

I just remembered that I had MinimumSDKVersion in /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Info.plist set to to 10.7 (instead of the default 10.12). My plugin compiles fine when I set this to 10.12 (and set OSX Base SDK Version and OSX Deployment Target to 10.12 in Projucer).

However if I understand correctly, setting MinimumSDKVersion to 10.7 (or such) in the Info.plist is required for savely building for old versions of Mac OS X.


#6

Nope, AFAIK setting the deployment target is sufficient to make the software running on the targeted OSX version. It is the best to leave the Base SDK as default.

An exception is e.g. building RTAS.


#7

Same here… I’m trying to convert a 3.2 project to the new 5.1.1 and I get the same errors. I tried deleting the current XCode exporter and make a new one, but without success.


#8

As mentioned above, you get this error if you are using a too old macOS sdk version. You should try building against the latest macOS SDK and set the deployment target version appropriately. Changing the minimum target is not needed for JUCE apps to run on older macOS versions - you just need to change the target sdk.

Those two layout tags are definitely defined in the latest SDKs. See here:
https://developer.apple.com/documentation/coreaudio/1572101-audio_channel_layout_tags/kaudiochannellayouttag_aac_7_1_b?language=objc