Component::bounds


#1

Do you think we could rename this private member variable to something more obscure, maybe some generous use of underscores or something.

Why? Because If you run with the default warnings set in VS2015 and use bounds in your resized method for example, perhaps in this very handy opening gambit…

void resized()
{
auto bounds = getLocalBounds();
s.setBounds(bounds.removeFromLeft(20));
//...

Then you get a compiler warning about shadowing a private member variable name …

It’s only annoying because I"ve started using ‘area’ instead as a variable name to avoid it, and then sometimes I’ve starting typing auto area = getLocalArea() by accident :slight_smile:


#2

suggestion for the new name of the member: componentBoundsInParent

sure it could clash again, but the name is so specific that client code could easily find an alternative


#3

OK. I renamed it on develop. I used boundsRelativeToParent instead of componentBoundsInParent as the latter sounds like the child’s bounds as expressed in the parent’s coordinate system (i.e. it doesn’t apply the child’s affine transforms).