So the idea is instead of this code:
comp2->setBounds(comp1->getX(), comp1->getBottom(), comp1->getWidth(), 24);
comp2->setBelow(comp1, height, topMargin = 0);
Similarly for all four side.
The resized code become more readable that way (and the jucer would be able to parse such statement and figure out the rule?).