CoreImage.framework not found after Xcode 7 upgrade


#1

Hi,

I get the errors:

 

Error loading /Users/..../Library/Audio/Plug-Ins/VST/MyPlugin.vst/Contents/MacOS/MyPlugin:  dlopen(/Users/...../Library/Audio/Plug-Ins/VST/MyPlugin.vst/Contents/MacOS/MyPlugin, 262): Library not loaded: /System/Library/Frameworks/CoreImage.framework/Versions/A/CoreImage

  Referenced from: /Users/...../Library/Audio/Plug-Ins/VST/MyPlugin.vst/Contents/MacOS/MyPlugin

  Reason: image not found

 

Any ideas how to solve this?

 

Thanks

 

 


Updating xcode. Possible issues?
#2

I had the same problem. I fixed it by changing the OSX compatibility version to 10.7. 


#3

Thanks for the tip.  

I copied a 10.9 SDK into Xcode 7's SDK's folder and set the base SDK to 10.9 in Introjucer.  That worked for me. 

 

 


#4

AFAIK nothing in juce actually directly includes CoreImage. If it's being indirectly included by another framework, then I really don't know why, and haven't seen this ourselves in Xcode 7


#5

So for those of us that were reckless enough to not have an old SDK laying around, what are our options here?

 

I'm getting that error in validation with a simple "Hello, world" plugin.


#6

As mentioned above, just change the compatibility version to something less than 10.11


#7

I've attempted that and am still getting the same error. I'll investigate more and see where the discrepancy is.


#8

Upgrade to El Capitan.  It fixes this issue


#9

DId anyone solve this? (without upgrading to ElCap?)

 


#10

I had to clean my project and rebuild before changing the Deployment Target had an effect.


#11

This is just because you're building for a different target OS than the one you're running on. For some reason Xcode by default on 10.10 will build apps that only run on 10.11 (doh!) so you need to explicitly dial it back to be 10.10 compatible (or earlier).

But you don't need to use an earlier SDK, you only need to change the "deployment target". You can do that in the Introjucer or Xcode.


#12

Changing the deployment target doesn’t seem to work for me. My program is running fine on 10.11 machines but 10.10 keeps getting the same error.

I know this is a somewhat old thread, but did any one else have any other fixes or ideas?


#13

It’s been a year since the last post, but it still doesn’t work. The issue is I can’t deploy to 10.10 or earlier, which is a total show stopper.

Using Xcode 7.3.1 on OS X 10.11.6

Has anyone had success with this in the meanwhile?


#14

Update: Properly setting the deployment target indeed fixes this.

In my case one of the compilation targets had a different setting that I wasn’t aware of, because I never set targets manually (use global xcconfig files). So I shot myself in the foot here. I’m sorry for the noise!