Custom modules not showing up in VS2015

projucer

#1

I"m not sure if I’m doing/not doing something silly, but I can’t seem to get a custom module to show up for a plugin in VS2015 after saving with Projucer. I.e. the module files do not get included in the project and result in “cannot open include file” errors.
(I know I should probably upgrade to VS2017!)

Updated to the latest tip on develop. The module shows up fine in Xcode, and I’ve double checked the module path is correct. Anything else that might be going wrong?


#2

Just saying, I did that with VS2015 on the weekend, and had no problems… So I don’t think that’s a reason to upgrade…

You probably checked, but I often find myself with two instances of the project open, one with the outdated project settings…


#3

Thanks, no only one copy open, tried closing and reopening VS, no joy.


#4

Looks like it was a path issue (doh); I ran Projucer on Windows to make sure paths were correct (which they obviously weren’t), and the problem is solved. I feel like an extra check and user feedback here might be useful, rather than the current assertion. Obviously this would only work on Windows.


#5

Didn’t the module turn red, when it wasn’t available?
I thought this was happening in the past, when a module folder was missing. Also it would not let you save, if a module is missing…


#6

Not on Mac, where the paths were correct. I was running Projucer on MacOS and loading the project in VS2015 in Parallels to compile for Windows. Lesson learned…!


#7

Ah, sure… it can’t possibly know that :slight_smile: