Debugging a plugin, but launches variables from another plugin

Hello all,

New to projucer and coding plugins.
I have created about 4 audio plugins so far, and all have worked reasonably well. I just started getting this issue where if I try to launch the plugin I am working on, the UI pops up, but the actual audio modification is from a plugin I am no longer working on.

For example:

I made a simple gain plugin called “AlexAudioGain” which simply has a slider that modifies the gain…
I closed this project, made another which is intending to modify phase with a very similar UI- but when I go to toggle the slider, it still modifies the gain.

Any ideas what is going on here? If I were more experienced I feel this would be an easy fix- but I am dumbfounded.



Did you give them different IDs in the project settings in Projucer? They need to have unique IDs defined there, or hosts will think they’re the same plugin. (Most do not go by the plugin name, but by their IDs.)

I am actually unsure… Where is that setting? I am looking through the exporters menu but don’t see an “ID” field- sorry bout being a noob.

It’s in the Settings for the Project. Click the gear-shaped icon up top and it will show the Settings panel.

Okay, I changed the ID, saved and launched Visual Studio 2019- and still the same issue.

What do you mean it still modifies the gain? Does a gain setting exist in that second plugin? Did you debug to see what it’s actually doing?

I assumed you meant it was still showing the first plug-in’s UI. Is that the case, or is it showing the correct UI, but just not modifying the right parameter?

If it’s showing the wrong plugin, then you still have the wrong ID someplace. What ID did you change? What host are you running in? It’s impossible to tell with no access to your code and not much description here about what is actually happening.

Yeah… I realize it’s ridiculous to ask these types of questions. So I made a beginners “gain” plugin that just effects the volume. In this plugin I simply modified the value of the data by multiplying by a float (0-1 on a slider). Thats it. One parameter, one slider.

In this new plugin I have two sliders, both of which don’t even have a gain parameter associated with them. One is a dry/wet setting and another is a feedback which hasn’t been coded yet.


I am using this to test if that slider value is being changed- but im not getting any output…