Demo audio plugin AUv3 not appearing in Garageband


#1

Hi, this isn’t appearing under AU extensions in GB, but appears in Audiobus so happy that it’s built and installed correctly.

Does GB have certain requirements/settings?

thx


#2

Is the standalone app installed on the device? If I build the AUv3SynthPlugin AUv3 AppExtension target from Xcode and select GarageBand as the app to run then the standalone app is installed and I can select the app extension from External -> Audio Unit Extensions menu and it works fine.


#3

hi, yes, standalone is installed fine. Have done exactly what you’ve done but nothing showing in the audio unit extensions page (other than other AUv3s that I’ve installed).

Just pulled latest dev, rebuilt projucer, rebuilt demo and still the same.


#4

Hi, is there anything I can do to try and diagnose why the plugin isn’t appearing? thx


#5

Can you get any other AUv3s built with JUCE to appear? Perhaps try creating a blank plug-in project and see if that shows up


#6

no, i can’t get anything to appear built by Juce, none of my own plugins show up and nor does a test project just created from scratch.


#7

What is the “Plugin AU Main Type” setting in the Projucer? I think it needs to be kAudioUnitType_MusicDevice for the AU to show up in Garageband.


#8

Ah, thanks - that was is - project defaults to kAudioUnitType_Effect.

Both test and my plugins are now showing up - thanks

(btw, where did you find the info that GarageBand only shows that type?)


#9

I think Garageband only supports AUv3 instruments, so effects don’t show up. If you tick the “Plugin is Synth” option in the Projucer then the default AU category will change to kAudioUnitType_MusicDevice.