e.source.enableUnboundedMouseMovement ( true ) broken?


#1

Hi

I’m trying to use

e.source.enableUnboundedMouseMovement ( true );

in a mouseDown on a Component. The mouse hides correctly, but when the ( invisible ) mouse moves offscreen or to another screen I get really strange mouse positions in my mouseDrag call.

I tried in de Juce Demo: something weird is going on there as well. Try the tab “Components Tabs & Widgets/ Sliders”. Slide the second vertical slider, the mouse will disappear, the puck will not move, the puck goes crazy when the invisible mouse goes offscreen.

Its on OSX 10.11.6 with JUCE 4.2.3

Am I doing something wrong or something else going on.

Kind regards,
Jankoen


#2

I can’t really reproduce this here (same OS version, same JUCE version, two monitors side-by-side).

The intended behaviour is that the puck moves very slowly. I’m surprised that you say that it doesn’t move at all.


#3

Hi Fabian

Thanks for looking into my problem.

I found what is causing my described behaviour: I’m always using my wacom tablet as a mouse ( in ‘pen’ mode ), and with this controller the behaviour is as described. When using a trackpad it indeed works fine and as expected.

So to the report should be added “when using a wacom tablet in ‘pen’ mode”


#4

We don’t have a wacom tablet here for me to test. You probably want to debug where the incorrect mouse coordinates are coming from. Try setting a breakpoint here.