/EHs compiler setting ignored


#1

In Visual Studio targets, adding the /EHs flag (so that functions declared extern “C” can still throw exceptions, required by Lua) is not applied to the resulting project file.


#2

You mean that just that flag is getting ignored, when other flags aren’t…?


#3

[attachment=0]Ehs.png[/attachment]


#4

But /EHs is a different flag to /EHsc, isn’t it?


#5

They are mutually exclusive:

[attachment=0]Ehs.png[/attachment]

How do I get /EHs set?


#6

I really don’t know, if the IDE is ignoring the flag then perhaps it’d need to be set via a project-setting in the XML, which would mean adding this option to the introjucer and getting it to generate the appropriate XML.