Enabling "Unity" is not persisted in Projucer

projucer

#1

In latest develop (696f26dea0):

  • Open the Projucer
  • Open an audio plugin .jucer project
  • Enable “Unity” in the “Plugin Formats”
  • Save the project
  • Close the project
  • Re-open the project. At this stage you’d expect “Unity” to be enabled, but it isn’t.

In the code I see that buildUnity isn’t listed with all the rest in getLegacyPluginFormatIdentifiers. And I wonder what makes all the other formats legacy? Do I sense a new plugin format coming from ROLI? :wink:


#2

The identifiers are legacy, not the plugin formats :wink:


#3

Are you using a Projucer that’s been compiled with the latest dev tip? I’m not able to reproduce this…


#4

I’m able to reproduce on the latest dev tip. The trick here is to be loading a project saved on an older Projucer build, in other words

  1. Make a new project using the current master build of the Projucer (or use an old project)
  2. Enable Unity and save the project using the develop branch Projucer
  3. Close and re-open that project - Unity won’t be enabled (unless you add it to the list of legacy plug-in identifiers in Project::getLegacyPluginFormatIdentifiers)

#5

Ah OK I see now, thanks. I’ll get that sorted out.


#6

Updating here too - appears fixed since https://github.com/WeAreROLI/JUCE/commit/af041a02d764e3120865664f5e4b8134914c2dd6