Error reading (*.mm) at Xcode

Hello. I’m new here, recently started watching video tutorials on a well-known channel, and today I decided to try programming something.

I downloaded Projucer, put it in the Applications folder (Mac OS X), launched it, opened the standard program template in Xcode, but when I tried to compile I got strange errors.

Has anyone come across a similar one?

The strangest thing is that the file is in the folder, but why Xcode cannot read it, I cannot understand.

While it is super simple to download Projucer, you are better off downloading from github and compiling Projucer yourself. This ensures you have the latest.

Downloaded, compiled, did not help.

Well… now your errors are different in that your .cpp files aren’t being found. Do they actually exist?

Yes, sure.

Before that I pointed out path to JUCE:

/Applications/JUCE

…and JUCE models:

/Applications/JUCE/models

Now I have reset settings to defaults — so Xcode does not start at all.

Ha, moved the folder with the application to the desktop, and it worked!)))