Error while running a blank android JUCE project in Android Studio with API 24


#1

Hey!
I wanted to write an android application with JUCE, but as soon as I ran the blank project exported via the Projucer, I got the following errors from Android Studio:

  1. uses or overrides a deprecated API:
    Documents\JUCE\AndroidTest\Builds\Android\app\src\main\java\com\yourcompany\androidtest\AndroidTest.java:
    uses or overrides a deprecated API.
    Recompile with -Xlint:deprecation for details.

  2. uses unchecked or unsafe operations:
    Documents\JUCE\AndroidTest\Builds\Android\app\src\main\java\com\yourcompany\androidtest\AndroidTest.java:
    uses unchecked or unsafe operations.
    Recompile with -Xlint:unchecked for details.

Any help in this regards?
Thanks!!


#2

Hi, those should just be warnings and are nothing to worry about.