File writing issue on Ventura

Hi guys,

one of my beta testers reported me a peculiar issue on Ventura. Basically, he saves a preset, then make some changes, then resave. At the second save, the writing fails with this error message:

After that, every write operation seems locked, including modifying the plugin settings (that are written in a dedicated file).

Anybody experienced something similar?


If he’s using a pre Ventura build and your checking the OS at runtime and not using compile time defines, that broke on the Ventura update

What path(s) are these files written to?
Does it make a difference if you change those paths?

@jakemumu default path locations are set using defines (JUCE_MAC, JUCE_WINDOWS). something like that:

                settings.defaultDocumentsPath = File::getSpecialLocation(File::commonDocumentsDirectory).getFullPathName();
                settings.defaultDocumentsPath = File::getSpecialLocation(File::commonDocumentsDirectory).getFullPathName();

@yfede all presets, licenses and setting files are located in /Users/Shared/MyCompany/
Never had issues before with that path and so far only this tester is having it.

Solved. Looks like the path I were providing to the file chooser was somewhat wrong. Strangely that worked fine since 2014, but maybe Ventura is treating that differently. Thread can be closed. Thanks!