FR: Fix standalone build with Bluetooth headphones

One slightly irritating thing is during development using standalone builds – while using bluetooth headphones connected to the computer, JUCE asserts and fails. I saw it mentioned in some other places, but I get a SR of 0 in the midi message collector.

It appears there are issues in a couple places, a good first step is not specify input channels needed, but then audio is also distorted coming to the bluetooth device.

Is it possible there are some some quick patches and macros we could add for this? I know it’s not a big issue – but it would significantly improve my development experience : )

Still a big irritation!

We’ve also had users reporting it… Anything we can do on our end to at least disable Bluetooth MIDI in the standalone?

yeah – honestly it would be amazing to just be able to boot standalone with audio entirely removed.

Then you could do UI work or whatever while listening to music, right now working with JUCE pretty much means JUCE dev or music but never both