Help needed: Building for x64 instead of x86 when using cmake

When I open the project in windows and compile my plugin, I see it compiles for x86 architecture. I would love to be able to compile for x64, but I don’t know if this is something that should be stated on the cmakelist.txt document, or I should do something different. Anyone can lend me a hand?

Ok, I see it was just a matter of configuring the compiler. Just in case anyone else is usong Clion on windows, he/she should go to toolchain settings at:

File / Settings / Build Execution Deployment / Toolchains

And there, in case you’re using Visual Studio compiler, be sure to enable the amd64 architecture instead of the x86 one.

That’s it!

1 Like