Help, please!


#1

I have made many attempts to compile something in Android. But I have not gotten anything. I tried several versions of the SDK. I tested on Windows, Linux, …
I have not managed to compile even a simple example. Always gives me an error of “ant”, or “old version”, or who knows what.
Can you give a detailed guide to compile a simple example (first telling the software to install, in detailed form, with the correct version). And, maybe, uploading the correct “Introjucer” version for generating the projects (I compiled from the last version 1.54.27, from the “modules” version, and from the git; neither compiles a “Introjucer” which could generate a compilable Android project).
And please, better if using the last NDK and SDK version (google system of versioning is annoying).
My health will thank you…

:frowning:


#2

Could you at least indicate the versions for the development environment you use (SDK, ADT, NDK, Eclipse, …)?

Edit: I’ve tried with (in Windows)
NDK: r7
SDK: r15 (I download the obsolete API 9 and 10)
ADT: 15.0.1
Eclipse: 3.7.1

“Introjucer” generates a basic example.
In Eclipse, I create a new project (Android), and specify the “Android” directory in “Builds”.
The project creates. I execute the “build.xml” with “Run as Ant -> Ant Built”

And then:

BUILD FAILED
C:\pruebas\Builds\Android\build.xml:36:

Error. You are using an obsolete build.xml
You need to delete it and regenerate it using
android update project

Edit2: Changing the path from:
c:/android-sdk-windows to c:\android-sdk-windows
c:/android-ndk-r7 to c:\android-ndk-r7
Appears to go beyond… but… In the project, there is a ("!") in “build.xml” in:

The error:
BUILD FAILED
C:\pruebas\Builds\Android\build.xml:12: taskdef class com.android.ant.SetupTask cannot be found
using the classloader AntClassLoader[]

This is a nightmare…

Introjucer config (in VisualStudio the program compiles and runs fine)


#3

Google keep updating their SDKs! My current set-up is the latest modules branch, with NDK r6b, but I’m going to update it this week to whatever the latest version is…


#4

Thanks!

But… my problem is the version? I’m not sure…

Edit: tried “android-ndk-r6b”, and the same error. :cry:


#5

Nothing new…?


#6

Yeah, I updated it all last week.


#7

Where are the updates?
With “Introjucer”, the last update was on July.
With “git”, I can see changes…

How can I download the changes?

Thanks in advance.

Javier.


#8

This thread is desperately begging for a new subject line…


#9

Hergest: you want the “modules” branch from GIT. (And I’m going to lock this far-too-vaguely named thread!)