IncDec Sliders and ToolTips


#1

Tooltips seem to get orphaned with inc/dec button sliders. They appear, but never disappear, and stay floating if the parent component moves away at all. Doesn’t happen with other slider types, in fact, using another slider type seems to ‘jog’ them, and they go away.

Bruce


#2

Can’t reproduce this on my mac… Can you suggest a way I could get it to happen in the juce demo?


#3

I’ll try. I should have mentioned then - I get this issue on:

iOS 4.2 on an iPhone, sliders set to inc/dec and with the sliding values thing active.

The parent component of the sliders is on a basic parent in a viewport.

Bruce


#4

Ah, well enabling tooltips on iOS is a bit of a non-starter, because there’s no mouse! All tooltips will just sit there until you actually click somewhere else.


#5

Sorry, I thought I implied, I should have said - it’s the little bubble that looks like a tool-tip but shows the slider value. Other slider types it goes away, inc/dec it gets stuck on screen.

Sorry I can’t pin it down a bit more - I’m on a plane in 2 hours. I’ll try to re-create when I can.


#6

Ah, gotcha. Ok, I’ll take a look.


#7

So, yeah, Juce demo on Mac shows the problem (sorry if you already fixed it).

Just add: sliders[4]->setPopupDisplayEnabled (true, page);

And the problem is visible.

Bruce


#8

I think I already fixed it. Haven’t tested, but I tweaked something that looked like it was the cause.


#9

That is how a true programmer operates!


#10

OK, now the popup appears when you do the drag actions, but not for the inc/dec actions? Is that what you intended?

Bruce


#11

um… no, maybe not. I’ll have another look!