*.inl File - Do Not Want in Binary Resources!


#1

Hi Jules,

Would like to request a way of either “unticking” or preventing specific file types from being part of the binary resources.

As it is, when using the OpenGL Mathematics Library, I’m stuck manually unticking all of their “*.inl” code files from being added to the binary resources file in the Introjucer (and there’s a lot of them, in multiple folders!).


#2

There has always been a tickbox for that! Click on the folder that contains the file, and it shows a list of settings for all its child files.


#3

I’m well aware of this list (I did add features to it, after-all); it does not cover modifying the “Add to Binary Resources” settings flag…
[attachment=1]Current options.png[/attachment]

Edit:
If you’re referring to this child file list, the difficulty is unticking all the files in one go - especially with a couple hundred files (bound to miss some).

[attachment=0]List of files and their options.png[/attachment]


#4

oh sorry, I didn’t notice that you were asking about doing it generically for file types. No… nothing in there to do that, the only way is to untick them all in the file list. Although TBH it might be worth hard-coding it treat .inl files like .h files by default.


#5

Ah, no worries… And you’re right - hard-coding the extension seems much simpler!


#6

I’m not sure why this happens, but after adding the “inl” extension to the following global variables

const char* const sourceFileExtensions          = "cpp;mm;m;c;cc;cxx;inl";
const char* const headerFileExtensions          = "h;hpp;hxx";
const char* const sourceOrHeaderFileExtensions  = "cpp;mm;m;c;cc;cxx;h;hpp;hxx;inl";

all the “.inl” files don’t get sorted in their groups in my VS project!


#7

It should be in the header file group, not the cpp files?


#8

Looks like implementation files to me… Regardless, moving the extension to the header file extensions var worked out!