Introjucer--can't create project


#1

I thought I’d use the Introjucer long enough to help me set up a framework for AAX. So I grabbed the tip code and built the introjucer inself (Xcode 3.2.6). I filled in the various parts of the form I needed, but found the button which actually creates the Xcode project to be inoperable. While I’m certainly no Introjucer expert, I don’t recall having a problem like this before. It was a matter of filling in what you wanted, making sure the Introjucer knew where the juce modules were, and hitting the button. Has some aspect of operation changed, or has my daily stupid pill kicked in?


#2

I get that when Introjucer looses focus, try clicking somewhere near the button so that Introjucer catches the focus the button should become active, theres always the top menu that has the save option


#3

Odd. Can you still reproduce that in the latest build? I changed a few focus things last week, but if if still happens and you can tell me how to reproduce it, I’d like to take a quick look.


#4

Just tried it with up-to-date code from the tip. Same issue. FWIW, I’ve enclosed a screen shot. You can see the buttons are present at lower left. They show tooltip information when you hover over them, but they don’t do anything. Modules are the latest as well, so I can’t think of any way the project would be incomplete.

Is it possible this is related to Xcode 3.2.6? I know you’d really like to move on from there (as would I), but I’m stuck with it for perhaps another little while (Pace-related).


#5

Won’t be Xcode related.

But what did you actually do to get it into that state? For me the buttons always seem to work as expected.


#6

[quote=“jules”]Won’t be Xcode related.

But what did you actually do to get it into that state? For me the buttons always seem to work as expected.[/quote]

All I did was create the project, uncheck VST/AU and check AAX. I changed a few values in the fill-in fields (company name, etc) and made sure the modules were pointed at the correct folders. That’s it. I thought it might be the AAX thing, so I also tried other variants like VST-only. I never was able to get it into a state where the buttons work, whether in Debug or Release builds. Guess I’ve just got that special touch, eh?


#7

I just tried this and was also puzzled for a second, but of course a brand new project can’t be opened, because it doesn’t yet have an Xcode exporter… When you add one of those, the buttons are enabled.

You also seem to be thinking that the button creates the Xcode exporter, but it launches it. You create the exporters by right-clicking on the treeview.

(but TBH I’m not sure why the new project wizard didn’t automatically create an Xcode exporter… I’ll check that)


#8

Hi Jules,

I'm having the same issue with the latest Juce version... am I missing something?

Thanks

 

Jean


#9

I thought my answer above was pretty clear..? There's no actual bug AFAIK, you just need to actually create an exporter for the buttons to work.