Introjucer not recognising valid Juce folder


#1

I’ve just downloaded the Introjucer, and then used this to download the latest version of Juce.
After I have done this the Juce updater recognises that Juce is in that folder and tells me the version, but then when I go to create a new project and select the folder, it comes up with red error text asking me to select a valid Juce folder…
I’ve tried deleting everything and starting again a couple of times, but still no joy. Am I missing something blindingly obvious?
This is all on mac.

Thanks for any help!


#2

Well, when it tells you to select a valid juce folder, presumably you’re not giving it the location of the version that you just downloaded… Otherwise it’d recognise it, right?


#3

Downloaded and re-installed everything again today and it worked first time :roll:
Must’ve been a sleepy sunday afternoon mistake!
Thanks for your help anyway.


#4

Do I need to download the actual juce source zip as well now?

I’m just setting stuff up fresh on my work computer, so I downloaded Introjucer, and it downloads the latest modules fine. However, even though it says I have all the latest versions, it doesn’t recognise the folder as a ‘juce’ folder, so it won’t actually let me create a new project.

[if I get the main zip, and select the unpacked folder, of course everything works fine… it’s just odd that it can’t work in a self-contained way any more]


#5

hmm… it’s probably just the folder name that confused it - it expects the folder to be called “modules”. I guess I should make sure it always downloads in a correctly named place…